JavaScript is disabled on your browser.

Modul Benutzer



Im Modul Benutzer werden alle Benutzerkonten eines Portals objektorientiert verwaltet. Die Objekte können in einer hierarchischen Struktur, die die Organisation abbildet, gespeichert werden. Ihnen steht ein sehr flexibles Datenmodell zur Verfügung, das mit der Definition eigener Objektklassen individuell erweitert werden kann.

In einem frisch angelegten Portal sind bereits Objektklassen mit Pflichtattributen definiert, wie z.B. die Objektklasse Benutzer mit den Pflichtattributen Vorname und Nachname. Diese Klasse besitzt eine Reihe von Attributen, mit denen ein Benutzer beschrieben werden kann.

Für jedes Attribut existiert ein Datenbankfeld, in dem die Werte, die Sie für eine Objektinstanz eintragen, gespeichert werden. Sie können eine unbegrenzte Anzahl von weiteren Attributen für eine Objektklasse definieren, die Pflichtattribute einer Klasse sind jedoch nicht änderbar.

Auf der Basis der Objektklassen werden Objekte (z.B. ein Portalbenutzer auf der Basis der Klasse Benutzer) angelegt. Objektklassen können wie eine Vorlage für die Objekte gesehen werden. Die spezifischen Werte eines Objekts werden in den Attributen gespeichert.

Im Schemamanager, den Sie im Menü Benutzer / Schemamanager erreichen, sehen Sie die Standard-Objektklassen der Intrexx Benutzerverwaltung.



Die Objektklassen Objekt, Container und Set sind sogenannte Basisklassen. Ihre Attribute werden an die Klassen, die von ihnen abgeleitet sind, vererbt. So hat z.B. die Klasse Benutzer neben den eigenen Attributen auch alle Attribute der Basisklasse Objekt, aus der sie abgeleitet ist. In der folgenden Abbildung sehen Sie eine Darstellung der Objektklassenhierarchie in der Intrexx Benutzerverwaltung.

Objekt anlegen



Im linken Bereich sehen Sie die Abbildung der Struktur in Baumform. Bei einem frisch angelegten Portal finden Sie hier nur den Portalknoten und den untergeordneten Ordner System. Ist der Portalknoten markiert, werden alle untergeordneten Objekte im rechten Bereich der Benutzerverwaltung aufgelistet. Dabei werden Sie über den Namen des Objekts, seine Beschreibung, den Typ und die Priorität informiert. In der Spalte Typ finden Sie die Objektklasse, der das Objekt angehört.

Benutzer löschen

Wird ein Benutzer gelöscht, was über das Kontextmenü Löschen bzw. das Menü Bearbeiten / Löschen möglich ist, wenn ein Benutzer markiert ist, so gilt für das entsprechende Profil in Intrexx Share 2.0: das Profil wird deaktiviert. In älteren Intrexx Share Versionen wird das Profil gelöscht.

Die Priorität kann bei der Mehrzahl der Objekte eingestellt werden und regelt die Reihenfolge, in der diese in der Benutzerverwaltung in Listen angezeigt werden.

Beim Ordner System handelt es sich um ein Container-Objekt. Wenn Sie diesen Ordner markieren, werden im rechten Bereich alle enthaltenen Objekte aufgelistet.

Ein neues Objekt kann sowohl im linken als auch im rechten Bereich über das Kontextmenü Neu angelegt werden.

Ansichten



über das Menü Ansicht können bei Bedarf zwei weitere Bereiche eingeblendet werden: Die Details, hier rechts oben, und ein Recherchefenster, hier im unteren Bereich.

Diese Reiter bzw. Bereiche des Moduls Benutzer können mit Klick auf das Symbol wieder ausgeblendet werden. Die Reiter lassen sich auch per Drag & Drop verschieben. Ziehen Sie den Reiter an seinem Titel auf die neue, gewünschte Position.

In der Baumansicht haben Sie die Möglichkeit, über das Menü Bearbeiten nach dem Vorkommen des aktuell selektierten Objekts in der Baumstruktur zu recherchieren. Das Ergebnis wird dabei im Recherchefenster angezeigt.



Mit einem Doppelklick auf ein Ergebnis wird die entsprechende Stelle, in der das Objekt in der Struktur vorkommt, im mittleren Bereich geöffnet.



Wenn Sie in der Listenansicht auf eine Klasse klicken, werden die Objekte dieser Klasse im mittleren Bereich angezeigt.



Die Tabellenspalten können über das Kontextmenü Tabellenspalten definieren angepasst werden. Wenn Sie weitere Spalten anzeigen möchten, verschieben Sie diese einfach mit Hilfe der Pfeiltasten in die Liste Ausgewählte Attribute. Die Reihenfolge der Spalten von kann mit den vertikalen Pfeiltasten geregelt werden.



In der Ansicht Suche haben Sie die Möglichkeit, nach einzelnen Objekten zu suchen. Wählen Sie in der Auswahlliste Typ den Objekttyp aus und tragen Sie den Suchbegriff im Suchfeld ein. Mit einem Klick auf Suchen werden alle Suchergebnisse im mittleren Bereich angezeigt.

Bei Mauskontakt mit einem im mittleren Bereich angezeigten Treffer werden zusätzliche Informationen eingeblendet. Alle Informationen zu einem bestimmten Objekt, wie z.B. GUID und ID, werden in einem Dialog aufgelistet, wenn Sie die Taste F4 drücken oder das Kontextmenü Details wählen.