JavaScript is disabled on your browser.

Editoren

Stylesheet-Editor

Im Modul Design erreichen Sie den Editor über das Menü Bearbeiten / Stylesheet bearbeiten. Hier haben Sie die Möglichkeit, Änderungen direkt in der dem Layout zugrunde liegenden CSS-Datei durchzuführen. Die Änderungen werden mit Klick auf OK übernommen und mit Veröffentlichung des Layouts wirksam.

JavaScript-Editor

Im Modul Applikationen finden Sie den Editor über den Reiter Skript im Eigenschaftendialog vieler Applikationselemente. Hier können Sie den Funktionsumfang von Applikationen mit JavaScript-Funktionen beliebig erweitern. Elemente, die per Skript ausgelesen oder gesteuert werden sollen, können ganz einfach referenziert werden. Mit dem Menü Bearbeiten / Einfügen wird eine Liste aller Eingabe- und Ansichtselemente, die sich auf der aktuellen Seite befinden, geöffnet. Wählen Sie das Element aus, das im Skript verwendet werden soll. Folgender Programmcode wird dann automatisch im Skripteditor eingefügt:

getElement("GUID des Elements")

Erstellen Sie Ihre Referenzen auf das HTML-Objekt mit der Syntax

var NameDesElements = getElement("GUID des Elements");

Bibliotheken

Im rechten Bereich des Editors finden Sie die Bibliotheken. über das Kontextmenü Alles ausklappen bzw. Alles einklappen können Sie den kompletten Baum ein- bzw. ausblenden, so dass Sie die untergeordneten Ebenen sehen bzw. nicht sehen. Im Suchfeld können Sie gezielt nach Stichwörtern suchen und diesen Filter auch wieder entfernen, wenn er nicht mehr benötigt wird. Die Intrexx Standardbibliothek enthält eine Sammlung von nützlichen Funktionen, die Sie ganz einfach in das Skript, das Sie im Editor verfassen, übernehmen können.

Neben der Intrexx Standardbibliothek können Sie weitere, eigene Bibliotheken mit den Funktionen anlegen, die Sie häufig benötigen. Sie erreichen dieses Feature über das Kontextmenü Neu / Bibliothek einfügen des Eintrags Bibliotheken.

Über das Kontextmenü Bearbeiten wird ein Dialog geöffnet, in dem Sie die Eigenschaften der neuen Bibliothek ändern können.

Neben der Intrexx Standardbibliothek können Sie über das Kontextmenü Neu weitere, eigene Bibliotheken anlegen. Die Datei wird dabei auf dem Client gespeichert. Der Speicherort hängt davon ab, wo die Intrexx-Installation des genutzten Portal Managers installiert ist. In der Regel finden Sie die Dateien in den folgenden Verzeichnissen: Für den Fall, dass die Installation auf einem Windows-Rechner unterhalb von C:\Program Files liegt, finden Sie die Dateien bei einer Standardinstanz in den folgenden Verzeichnissen: Für den Fall, dass die Installation auf einem Windows-Rechner unterhalb von C:\Program Files liegt, finden Sie die Dateien bei einer benutzerdefinierten Instanz in den folgenden Verzeichnissen: Die Dateien bleiben beim Update erhalten.

Wenn Sie eine URL auf eine Seite Ihrer Wahl eingetragen haben, wird das Weltkugelsymbol im Vorschaufenster unten rechts eingeblendet. Ein Klick auf dieses Symbol öffnet die Webseite im Browser.

über das Kontextmenü Neu / Kategorie einfügen einer Bibliothek können Kategorien für die Gliederung Ihrer Bibliothek angelegt werden.

Wie bei einer Bibliothek können Sie auch bei einer Kategorie den Titel, die Beschreibung und einen Link auf eine Webpage Ihrer Wahl über das Kontextmenü bearbeiten.

Funktionen, die Sie häufig verwenden, können Sie hier in den sogenannten Templates verwalten. Legen Sie ein Template über das Kontextmenü Neu / Template einfügen einer Kategorie an.

Wenn Sie das Template in der Baumstruktur markieren, wird das enthaltene Skript im Vorschaufenster unten rechts angezeigt. Von dort aus können Sie über Bearbeiten wieder den Dialog öffnen, in dem das Skript verfasst wurde. Beschreibung blendet die Beschreibung des Templates ein.

Das Skript aus dem Template kann über das Kontextmenü In das Skript einfügen in das bestehende Skript im linken Bereich des Editors an der aktuellen Cursorposition eingefügt werden.

Wenn Ihr Skript fertig gestellt ist, kann es mit Klick auf OK gespeichert werden. Alle Änderungen werden nach der Veröffentlichung der Applikation wirksam.

Das Erstellen, Bearbeiten, Löschen und Importieren von benutzerdefinierten Bibliotheken ist deaktiviert, wenn der aktuelle Benutzer keine Schreibrechte am jeweiligen Ordner besitzt. Falls erforderlich, müssen diese Schreibrechte manuell durch den Administrator gesetzt werden. Bibliotheken können über das Kontextmenü exportiert und gelöscht werden.

Applikationsstruktur

Auf diesem Reiter wird die Applikationsstruktur abgebildet. Wird ein Element in der Baumstruktur markiert, so werden im unteren Bereich diverse Eigenschaften wie z.B. GUID oder Name des Elements angezeigt. Mit Klick auf dieses Symbol wird der entsprechende Wert in das Skript eingefügt.

Funktionen

Auf diesem Reiter werden die im aktuellen JavaScript definierten Funktionen auflistet. Im oberen Bereich kann nach Funktionsnamen gesucht werden. Mit Filter zurücksetzen werden Suchbegriffe aus dem Suchfeld entfernt und die Filterung aufgehoben. Mit Sortieren wird die alphabetisch sortierte Reihenfolge der Funktionsnamen aufsteigend bzw. absteigend geändert. Ist Verbinden mit Editor aktiv, so wird bei Klick auf einen Funktionsnamen automatisch der Editor aktualisiert und der Cursor am Anfang der entsprechenden Funktion positioniert.

JSDoc

Öffnet eine Liste mit den verfügbaren JSDoc-Tags an der Cursorposition. JSDoc dient der Dokumentation von Funktionen. Mit diesem Menü können JSDocs verfasst werden, die die Transparenz Ihrer Funktionssammlung deutlich erhöhen. Folgende JSDoc-Tags werden unterstützt: Wählen Sie den gewünschten Tag aus. Der Tag muss in einem Kommentar eingesetzt werden. Tragen Sie direkt danach die Begriffe ein, die Sie im Bereich Dokumentation auf dem Reiter Funktionen sehen wollen, wenn Sie dort eine Funktion auswählen.

Groovy-Skripteditor

Den Groovy-Skripteditor finden Sie im Modul Integration beim Datentransfer, wenn als Datenquelle oder Ziel Groovy-Skript gewählt wird. Außerdem ist er auch im Modul Prozesse erreichbar.

Wie im JavaScript-Editor sind im rechten Bereich Bibliotheken, Kategorien und Templates erreichbar. Die Intrexx Standardbibliothek bietet auch hier eine Fülle von Objekten und Funktionen, die Sie in Ihr bestehendes Skript übernehmen können. Über die gleichnamigen Reiter im rechten Bereich haben Sie auch hier Zugriff auf Elemente aus der Applikationsstruktur und Funktionen.

Velocity-Editor

Der Velocity-Editor ist im Modul Prozesse erreichbar. Wenn Sie eine E-Mailaktion definieren, können Sie hier Meldungen aus dem Kontext verfassen.

Formel-Editor

Diesen Editor erreichen Sie über die Berechnungskontrolle im Applikationsdesigner.

Auf dem Reiter Bibliotheken stehen hier Formelausdrücke zur Auswahl. Der gewählte Formelausdruck wird im Skript entweder an der aktuellen Cursorposition eingefügt oder ersetzt den aktuell selektierten Textabschnitt.

Manche Formeln enthalten Platzhalter für Parameter in der Form ${parameter}. Klickt man im Skript mit der Maus auf einen solchen Platzhalter, wird dieser selektiert und kann entweder manuell oder durch einen Wert oder einen weiteren Formelausdruck ersetzt werden.

Über das Kontextmenü oder das Menü Bearbeiten / Wert einfügen kann ein Wert aus der Applikation eingefügt werden, z.B. die GUID einer Kontrolle oder eines Datenfeldes. Ist eine GUID oder der Name einer Kontrolle im Skript selektiert, können mit der Taste F2, weitere Informationen zu dem Objekt in einem Tooltip abgerufen werden, soweit die GUID bzw. der Name der Kontrolle bekannt ist.

Mit der Tastenkombination Strg + Leertaste können Formeln in einem Tooltip ausgewählt werden. Wenn z.B. der Begriff sum im Editor eingeben ist und die o.g. Tastenkombination angewendet wird, werden Formeln, die mit sum beginnen, vorgeschlagen.

Wird ein Parameter-Schlüsselwort in einer Formel selektiert, so wird das Kontextmenü auf den jeweiligen Parameter-Typ gefiltert. Weitere Informationen finden Sie hier:

http://docs.intrexx.com/intrexx/version/7000/api/formula/overview.redirect

Menü Bearbeiten

Zwischenspeichern

Mit diesem Menü wird der Code lokal gespeichert. Wird der Editor mit Abbrechen geschlossen, so werden alle bereits zwischengespeicherten Änderungen übernommen.

Einfügen

Mit dem Menü Bearbeiten / Einfügen wird eine Liste aller Elemente, die sich auf der aktuellen Seite befinden, geöffnet. Wählen Sie das Element aus, das im Skript verwendet werden soll.

Rückgängig

Macht den letzten Bearbeitungsschritt im Skript rückgängig.

Wiederholen

Wiederholt den letzten Bearbeitungsschritt.

Suchen

öffnet einen Dialog, in dem Begriffe im Skript gesucht und ersetzt werden können.

Zeile löschen

Löscht die Zeile im Skript, in der sich der Cursor aktuell befindet.

Gehe zu Zeile

öffnet einen Dialog, in dem eine Zeilennummer eingetragen werden kann, die im Editor ausgewählt werden soll.

Block ein- / auskommentieren

Fügt // im Skript ein, um eine Zeile in einen Kommentar umzuwandeln.

In Bibliothek suchen

Springt zum Suchfeld auf dem Reiter Bibliotheken

Funktion suchen

Springt zum Suchfeld auf dem Reiter Funktionen

JSDoc einfügen

öffnet eine Liste mit den verfügbaren JSDoc-Tags an der Cursorposition. JSDoc dient der Dokumentation von Funktionen. Mit diesem Menü können JSDocs verfasst werden, die die Transparenz Ihrer Funktionssammlung deutlich erhöhen.

Folgende JSDoc-Tags werden unterstützt: @author, @deprecated, @description, @example, @param, @private, @public, @returns, @throws, @version. Wählen Sie den gewünschten Tag aus. Der Tag sollte im Bereich eines Kommentars eingesetzt werden. Tragen Sie direkt danach die Begriffe ein, die Sie im Bereich Dokumentation auf dem Reiter Funktionen sehen wollen, wenn Sie dort eine Funktion auswählen.

Syntaxprüfung

Die Syntaxprüfung weist Sie auf unvollständige Klammerpaare und andere nicht plausible Stellen im Skript hin.

Leerzeichen / Tabs am Zeilenende beim Beenden löschen

Ist dieser Menüpunkt aktiviert, werden beim Beenden des Editors überflüssige Leerzeichen und Tabs am Ende von Skriptzeilen gelöscht.

Menü Ansicht

Funktionen einblenden

Blendet den Reiter Funktionen ein bzw. aus.

Bibliotheken einblenden

Blendet den Reiter Bibliothekenein bzw. aus.

Applikationsstruktur einblenden

Blendet den Reiter Applikationsstrukturein bzw. aus.

Standardansicht wiederherstellen

Stellt die ursprüngliche Ansicht des Editors nach einem Neustart des Portal Managers wieder her.

Vollbild

Maximiert den Editor.

Marker setzen

Beim öffnen einer Applikation oder eines Prozesses wird JavaScript und Groovy nach Kommentaren, die die Zeichenfolge //FIXME oder //TODO enthalten, durchsucht. Die Ausdrücke FIXME oder TODO müssen dabei direkt nach dem Kommentarzeichen folgen. Treffer werden im Bereich Hinweise mit diesem Symbol angezeigt. Mit einem Doppelklick auf einen Treffer wird der entsprechende interne Editor geöffnet. Die Kommentarzeile wird auch hier wieder mit diesem Symbol in der Spalte links im Editor gekennzeichnet. In der Statuszeile werden die Anzahl der Tasks, sowie die Zeile des ersten Tasks angezeigt.